Follow

CentOS勢、masterに追加された blurhash というgemのインストールでコケると思います。原因は gcc が 4.8.5 と古いためのようです

· Web · 1 · 14 · 12

これ ( qiita.com/bezeklik/items/967aa ) を参考にgccを上げました。記事には 5.2 と書いてありますが gcc 5.3.1 になります。
PATHに /opt/rh/devtoolset-4/root/usr/bin を書き加えます。
これで gcc は OK ですが「認識できないオプション」とかいうエラーが出てまだコケるので、リンカというのを ld から ld.gold に置き換えたらいいようです

リンカの置き換えはシンボリックリンクを張るだけです
# mv /opt/rh/devtoolset-4/root/usr/bin/ld /opt/rh/devtoolset-4/root/usr/bin/ld.bak
# ln -s /opt/rh/devtoolset-4/root/usr/bin/ld.gold /opt/rh/devtoolset-4/root/usr/bin/ld

@yi0713 説明ありがとうございます🙏2.8.1アップデートの際に参考にさせていただきます!!

@yi0713 うちもエラーがでて困ってましたが、ヒントになりました。すごく助かりました。ありがとうございます!

@lucida3rd いえいえ!お役に立てたなら何よりで、嬉しいです!

Sign in to participate in the conversation
mstdn.jp

Mastodon日本鯖です.